Skip to content

Upgrade fails if location hours tables already exist #500

Description

@bwsmmiller

Describe the bug
If the location hours tables already exist, upgrading fails as the scripts always attempt to create the new tables.

To Reproduce
Steps to reproduce the behavior:

  1. Start with a server 5.3.1+
  2. Revert to a previous server version.
  3. Upgrade back to 5.3.1+
  4. Upgrade will fail attempting to create tables that already exist.

Expected behavior
The script should return an error indicating that the tables already exist, but allow the upgrade to complete.

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    Type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions