Repository navigation
[Aikido] Fix security issue in pytest via major version upgrade from 8.4.0 to 9.2.0 - #28
Open
aikido-autofix[bot] wants to merge 1 commit into
Open
aikido-autofix[bot] wants to merge 1 commit into
aikido-autofix[bot] wants to merge 1 commit into
Conversation
|
Important Review skippedBot user detected. To trigger a single review, invoke the
|
This branch has not been deployed
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Description
Upgrade pytest to fix local privilege escalation and denial of service vulnerabilities in temporary directory handling.
Motivation and Context
Fixes #(issue)
Security Impact — CVE vulnerabilities fixed by this PR:
✅ 1 CVE resolved by this upgrade
This PR will resolve the following CVEs:
Fix Details / Technical Implementation (detailed write-up of what was changed and why):
🤖 Remediation details
Fix CVE-2025-71176: upgrade
pytestto patched version ≥ 9.0.3Short summary
This PR remediates a security vulnerability in
pytestby raising its declared lower bound in both dependency sections of the rootpyproject.toml. The lockfileuv.lockwas regenerated to reflect the new resolved version. Becausepytest ≥ 9.0.3requires Python ≥ 3.10, the project'srequires-pythonwas also narrowed from>=3.8to>=3.10to eliminate marker forks that would have left vulnerable pytest versions pinned for Python 3.8/3.9 splits.pytest
pytestis declared as a direct dependency in two places inpyproject.toml:[project.optional-dependencies] dev(previously>=7.0.0) and[dependency-groups] dev(previously>=8.3.5). Both lower bounds were raised to>=9.0.3to satisfy the patched version floor. The initial lock attempt failed becausepytest ≥ 9.0.3drops support for Python < 3.10, causing the resolver to produce unsatisfiable marker forks for the Python 3.8 and 3.9 splits still covered byrequires-python = ">=3.8"; leaving those forks in place would have kept vulnerable pytest versions active on those Python versions. Narrowingrequires-pythonto>=3.10collapsed the forks, anduv lockresolved a singlepytestinstance at 9.2.0 across all supported Python versions.Version changes
pytest8.3.5/8.4.0(marker forks)9.2.0pytest-asyncio0.24.0/1.1.0(marker forks)1.4.1.post1requires-pythonnarrowingpluggy1.5.0/1.6.0(marker forks)1.6.0requires-pythonnarrowingcoverage7.6.1/7.8.2(marker forks)7.8.2requires-pythonnarrowingmypy1.14.1/1.16.0(marker forks)1.16.0requires-pythonnarrowingtyping-extensions4.13.2/4.14.0(marker forks)4.14.0requires-pythonnarrowingurllib32.2.3/2.4.0(marker forks)2.4.0requires-pythonnarrowingpytest-cov5.0.0/6.1.1(marker forks)6.1.1requires-pythonnarrowingType of Change
How Has This Been Tested?
Test Commands:
uv run pytest # or specific test commandTest Configuration:
Checklist
ruff checkandruff format --check)uv run pytest)uv run mypy src/)Additional Notes