Skip to content

Update Requests security fixes and align the Python requirement - #165

Merged
LakshyAAAgrawalP merged 1 commit into
mainfrom
fix/requests-security-python-floor
Oct 12, 2026
Merged

LakshyAAAgrawalP merged 1 commit into
mainfrom
fix/requests-security-python-floor

Conversation

@LakshyAAAgrawal

Copy link
Copy Markdown
Collaborator

Upgrade Requests from 2.32.3 to 2.33.0 in both dependency manifests, fixing the two advisories currently reported against those pins:

Compatibility change: Requests 2.33.0 requires Python 3.10+. Raise multilspy's package metadata to match and make the requirement explicit in the installation documentation. CI already tests Python 3.10, 3.12, and 3.14. This replaces the dependency-only update proposed in #151 with consistent Python compatibility metadata; Python 3.8/3.9 are no longer supported by this change.

Validation: built the wheel and verified its Requires-Python and Requests dependency metadata. Installed it with the requirements in clean Python 3.10 and 3.14 environments; dependency checks and four real Jedi/Black integration tests pass on each. On both interpreters, also exercised FileUtils.download_file against an HTTP server, verifying a 1 MiB binary stream byte-for-byte and rejection of HTTP 404.

@LakshyAAAgrawalP
LakshyAAAgrawalP merged commit 39a2efa into main Oct 12, 2026
6 checks passed
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Labels

None yet

Projects

None yet

Development

Successfully merging this pull request may close these issues.

2 participants