Skip to content

Update HTA dependency to the traceinsight package - #233

Open
mihncalo wants to merge 3 commits into
mlcommons:mainfrom
Keysight:pr-217
Open

mihncalo wants to merge 3 commits into
mlcommons:mainfrom
Keysight:pr-217

Conversation

@mihncalo

@mihncalo mihncalo commented Oct 27, 2026 •

Copy link
Copy Markdown

Summary

Reviewed the original PR from mlcommons/chakra ( #217 ) and addressed the comments left on that PR.

Test Plan

Environment used for testing

Python 3.13, torch 2.9.0+cu128, traceinsight 0.6.1, PARAM et_replay, networkx 3.6.1.

How the testing was done

  • Updated pyproject.toml to use requires-python 3.10 and ruff target-version py310, to prepare the environment ( these changes will come from the PR for Issue Raise requires-python to >=3.10 #224 )
  • Created a clean environment using python 3.13.17, to test with both pandas 2.x and 3.x
  • Followed the USER_GUIDE.md
  • Ran python -m pytest tests: All 117 tests are passing, 1 warning: DeprecationWarning: Python 3.14 will, by default, filter extracted tar archives and reject files or modify their metadata. Use the filter argument to control this behavior
  • Ran the simple_onerank.py and simple_multirank.py scripts in trace_collection/post_execution/ to generate the required traces
  • Ran chakra_trace_link using both pandas 2.3.3 and pandas 3.0.6 and collected the logs
  • Ran chakra_converter on the resulted linked traces to generate the .et files and collected the logs

Results

The logs show that:

  • critical path runs: critical_path_analysis.py:1487 [INFO]: calculating critical path took 0.001714 seconds
  • the host and device traces are linked successfully: Linking process successful. Output file is available at ...
  • the linked traces are converted into .et files successfully: Conversion successful. Output file is available at ...

Additional Notes

  • Pandas 3.x needs at least python 3.11, which means that requires-python will need to be raised in the future.
  • A comment on the original PR refers to pinning networkx >=3.6.1. That would require a minimum Python version of 3.11, which requires-python doesn't enforce right now. I decided not to address the comment in this PR.

Closes #235

@github-actions

Copy link
Copy Markdown

MLCommons CLA bot All contributors have signed the MLCommons CLA ✍️ ✅

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Labels

None yet

Projects

None yet

Development

Successfully merging this pull request may close these issues.

Replace the git-pinned HTA dependency with traceinsight

2 participants